Severity: High

Description

Browser information is not filtered properly while saving the session values into the database which leads to a Remote Code Execution vulnerability.

Affected Installs

Joomla! CMS versions 1.5.0 through 3.4.5

Solution

Upgrade to version 3.4.6

 

 

Backup your Joomla files and database first.

Get Joomla update alerts by email here

Severity: High

Description

Inadequate filtering of request data leads to a SQL Injection vulnerability.

Affected Installs

Joomla! CMS versions 3.2.0 through 3.4.4

Solution

Upgrade to version 3.4.5

 

Backup your Joomla files and database first.

Get Joomla update alerts by email here

Description

Important security update.

Affected Installs

Joomla! CMS versions 3.0 through 3.4.4

Solution

Upgrade to version 3.4.5

 

Backup your Joomla files and database first.

Get Joomla update alerts by email here

Description

Inadequate checking allowed the potential for remote files to be executed.

Affected Installs

Joomla! CMS versions 2.5.4 through 2.5.25, 3.2.5 and earlier 3.x versions, 3.3.0 through 3.3.4

Solution

Upgrade to version 2.5.26, 3.2.6, or 3.3.5

 

Backup your Joomla files and database first.

Get Joomla update alerts by email here

Description

Inadequate filtering leads to XSS vulnerability in highlighter plugin.

Affected Installs

Joomla! version 2.5.9 and earlier 2.5.x versions; and version 3.0.2 and earlier 3.0.x versions.

Solution

Upgrade to version 2.5.10,  3.1.0 or 3.0.4.

Backup your Joomla files and database first.

Get Joomla update alerts by email here

SSL Secure Connection